"New Change Order" Unresponsive
Incident Report for inBuild
Resolved
This issue has been resolved and the "new change order" button is working as expected.
Posted Dec 06, 2023 - 23:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 06, 2023 - 23:17 UTC
Investigating
The "new change order" button is unresponsive for all users. We are currently investigating the issue further.
Posted Dec 06, 2023 - 22:57 UTC
This incident affected: inBuild Application.